UMD-3:UMD-3.1.1

From EGIWiki
Revision as of 14:50, 28 June 2013 by Jpina (talk | contribs) (Created page with "{{Template:Op menubar}} {{Template:Middleware_menubar}} {{TOC_right}} = '''UMD 3.0.0 : Additional information for provided products''' = While undergoing the EGI Softw...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Main EGI.eu operations services Support Documentation Tools Activities Performance Technology Catch-all Services Resource Allocation Security


Middleware menu: Home Software Calendars Technology Providers UMD Release Schedule UMD Products Overview UMD Products ID Cards Release and deployment process Middleware Requirements Next middleware release



Contents


UMD 3.0.0 : Additional information for provided products

While undergoing the EGI Software Provisioning process, some installation issues and known problems were detected and documented. This document provides the same information, in one single place, where site admins may learn about the provided software prior to installation or, with later updates to UMD-3, upgrading their systems.

Each section that follows will be linked by the relevant sections provided in the EGI Software Repository for this release of UMD.



Scientific Linux 5

emi.lfc.sl5.x86_64

  • Additional Details:
  • Installation Notes: There are some dependency problems (already included in the release notes) GGUS
  • Known Issues:No issues found during EGI's Software Provisioning.
  • Version:1.8.6

emi.bdii-site.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.2.0

emi.bdii-top.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues:
    • Due to the caching mode, decommissioned services are published as 'Production' until the cache expires. Savannah BUG #99298
    • The glite-info-update-endpoints script does not fail when using the manual option and the input file does not exist. Savannah BUG #99322
  • Version: 1.1.0

emi.dpm.sl5.x86_64

  • Additional Details:
  • Installation Notes: There is a dependency issue with lcgdm-dav GGUS TICKET
    • Workaround: remove obsolete packages:
# yum remove emi-dpm_mysql gridsite-libs emi-version emi-dpm_disk gridsite 

and install again DPM metapackage

# yum install emi-dpm_mysql emi-dpm_disk
  • Known Issues: In some cases you may have conflicting UIDs/GIDs since uids and gids < 201 are reserved which was not mandatory in previous versions.
  • Version: 1.8.6

emi.argus.sl5.x86_64

  • Additional Details:
  • Installation Notes:
    • Due to missing dependencies in the emi-argus metapackage it is needed to install fetch-crl package by hand prior to any other installation.Workaround
  • Known Issues:
    • Because SL6 uses the NSS library instead of OpenSSL, the proxy are not correctly handled this means Argus interoperabilty with WMS in SL6 is not working. GGUS TICKET
    • Argus DN with EMAILADDRESS will fail GGUS TICKET
  • Version: 1.6.0

emi.bdii-core.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.5.0

emi.canl.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.0.7

emi.emi-ui.x86_64

  • Additional Details:
    • Detailed release notes: Full release notes can be consulted here
  • Installation Notes:Several dependencies issues found please read carefully the release notes
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 3.0.0

emi.yaim-core.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:5.1.1

emi.emi-wn.sl5.x86_64

  • Additional Details:
  • Installation Notes:
    • When upgrading from EMI-2 version wn there is an issue with the upgrad of voms-clients package:
# yum remove voms-clients
# yum install emi-wn
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.0.0

emi.glexec-wn.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:1.2.0

emi.gfal-lcg_util.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 3.0.0

emi.gsoap-gss.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.2.0

emi.lb.sl5.x86_64

  • Additional Details:
  • Installation Notes: Backward Incompatible: DB schema change. Configuration scripts update the DB automatically, manual update script provided.
  • Known Issues: Setup script may fail when unable to find messaging brokers through BDII (reporting:"glite-lb-setup: ERROR: msg, ABORT: glite-lb-setup failed!") GGUS
    • Solution: provided in the release notes
  • Version: 4.0.4

emi.lcg-info-clients.sl5.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:1.0.1

emi.torque-wn.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.0.0

emi.wms.sl5.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes:
  • Known Issues:
    • wrong information published by EMI-3 WMS GGUS
  • Version: 3.5.0

emi.gridsite.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.0.4

IGE.globus-32-bit.sl5.x86_64

  • Additional Details:
    • Detailed release notes: Globus 32 bit libraries needed to satisfy emi-wn dependencies
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:5.2.4

emi.cream.sl5.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues:
    • By default this CREAM release installs the APEL 2.1.0 parsers, please read the APEL known issues.
    • If making fresh install, and you do not want to move to the new APEL clients, please read how to set CREAM to use APEL from UMD-2 wiki
    • The are some issues after configuring with yaim
  • Version: 1.15.1

emi.cream-torque.sl5.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.1.0

emi.cream-torque-server.sl5.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.0.1-2

emi.apel.sl5.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning but sites should be aware of the following:
  • To use new APEL server sites should be aware that this version (4.1.0) of APEL Publisher is compatible only with APEL Parsers 2.1.0 and above. Sites installing EMI-3 APEL should follow the instructions in the APEL Client Upgrade Plan which can be found here
    • This APEL version publish information to a different server, meaning sites needs to previously open a GGUS ticket to APEL in order to be allowed to publish to new server.
    • In production sites are not allowed to publish to both servers, nevertheless during test period you will allowed to publish to both.
  • Known Issues:
    • ** IT is recomended to use CREAM 1.15.1 or higher (EMI-3).
  • Version:4.1.0

Scientific Linux 6

emi.lfc.sl6.x86_64

  • Additional Details:
  • Installation Notes: There are some dependency problems (already included in the release notes) GGUS
  • Known Issues:No issues found during EGI's Software Provisioning.
  • Version:1.8.6

emi.bdii-site.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.2.0

emi.bdii-top.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues:
    • Due to the caching mode, decommissioned services are published as 'Production' until the cache expires. Savannah BUG #99298
    • The glite-info-update-endpoints script does not fail when using the manual option and the input file does not exist. Savannah BUG #99322
  • Version: 1.1.0

emi.dpm.sl6.x86_64

  • Additional Details:
  • Installation Notes: There is a dependency issue with lcgdm-dav GGUS TICKET
    • Workaround: remove obsolete packages:
# yum remove emi-dpm_mysql gridsite-libs emi-version emi-dpm_disk gridsite 

and install again DPM metapackage

# yum install emi-dpm_mysql emi-dpm_disk
  • Known Issues: In some cases you may have conflicting UIDs/GIDs since uids and gids < 201 are reserved which was not mandatory in previous versions.
  • Version: 1.8.6

emi.argus.sl6.x86_64

  • Additional Details:
  • Installation Notes:
    • Due to missing dependencies in the emi-argus metapackage it is needed to install fetch-crl package by hand prior to any other installation.Workaround
  • Known Issues:
    • Because SL6 uses the NSS library instead of OpenSSL, the proxy are not correctly handled this means Argus interoperabilty with WMS in SL6 is not working. GGUS TICKET
    • Argus DN with EMAILADDRESS will fail GGUS TICKET
  • Version: 1.6.0

emi.bdii-core.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.5.0

emi.canl.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.0.7

emi.emi-wn.sl6.x86_64

  • Additional Details:
  • Installation Notes:
    • When upgrading from EMI-2 version wn there is an issue with the upgrad of voms-clients package:
# yum remove voms-clients
# yum install emi-wn
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.0.0

IGE.globus-32-bit.sl6.x86_64

  • Additional Details:
    • Detailed release notes: Globus 32 bit libraries needed to satisfy emi-wn dependencies
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:5.2.4

emi.yaim-core.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:5.1.1

emi.emi-ui.x86_64

emi.wms.sl6.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes:
  • Known Issues:
    • Because SL6 uses the NSS library instead of OpenSSL, the proxy are not correctly handled this means Argus interoperabilty with WMS in SL6 is not working. GGUS TICKET
    • wrong information published by EMI-3 WMS GGUS
  • Version: 3.5.0

emi.torque-wn.sl6.x86_64

  • Additional Details:
    • Detailed release notes:
  • Installation Notes:
  • Known Issues:
  • Version:

emi.lb.sl6.x86_64

  • Additional Details:
  • Installation Notes: Backward Incompatible: DB schema change. Configuration scripts update the DB automatically, manual update script provided.
  • Known Issues: Setup script may fail when unable to find messaging brokers through BDII (reporting:"glite-lb-setup: ERROR: msg, ABORT: glite-lb-setup failed!") GGUS
    • Solution: provided in the release notes
  • Version: 4.0.4

emi.lcg-info-clients.sl6.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:1.0.1

emi.gsoap-gss.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.2.0

emi.glexec-wn.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:1.2.0

emi.gridsite.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.0.4

emi.gfal-lcg_util.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 3.0.0

emi.cream.sl6.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues:
    • By default this CREAM release installs the APEL 2.1.0 parsers, please read the APEL known issues.
    • If making fresh install, and you do not want to move to the new APEL clients, please read how to set CREAM to use APEL from UMD-2 wiki
    • The are some issues after configuring with yaim
  • Version: 1.15.1

emi.cream-torque.sl6.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.1.0

emi.cream-torque-server.sl6.x86_64

  • Additional Details:
    • Detailed release notes: here
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 1.0.1-2

emi.apel.sl6.x86_64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning but sites should be aware of the following:
  • To use new APEL server sites should be aware that this version (4.1.0) of APEL Publisher is compatible only with APEL Parsers 2.1.0 and above. Sites installing EMI-3 APEL should follow the instructions in the APEL Client Upgrade Plan which can be found here
    • This APEL version publish information to a different server, meaning sites needs to previously open a GGUS ticket to APEL in order to be allowed to publish to new server.
    • In production sites are not allowed to publish to both servers, nevertheless during test period you will allowed to publish to both.
  • Known Issues:
    • ** IT is recomended to use CREAM 1.15.1 or higher (EMI-3).
  • Version:4.1.0

Debian 6

emi.canl.debian-squeeze.amd64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 2.0.7

emi.gsoap-gss.debian-squeeze.amd64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.2.0