Agenda-06-05-2013

From EGIWiki
Jump to: navigation, search
Audio conference link Conference system is Adobe Connect, no password required.
Audio conference details Indico page


1. Middleware releases and staged rollout

1.1 Staged Rollout

Status of the products verification/staged rollout

For UMD-3 a comprehensive view can be found in this RT dashboard. Please note that the page could take time to load.


UMD-3: Products in staged rollout

  • Apel 4.0.0
  • Arc-ce 3.0.0 (deprecated due to 3.0.1 release)
  • Arc-infosys 3.0.0 (deprecated due to 3.0.1 release)
  • unicorex6 6.0.0
  • unicore-tsi6 5.1.0
  • unicore-client6 6.0.0
  • unicore-registry6 6.0.0
  • unicore-xuudb 2.0.0
  • unicore-gateway 5.0.0
  • unicore-hila 2.4.0
  • glexec-wn 1.2.0
  • torque-server 1.0.1
  • cream-torque 2.1.0
  • cream 1.15.1

Issues found during staged rollout

  • CREAM glite-ce-delegate-proxy fails after EMI2 to EMI3 upgrade GGUS
  • APEL having allot of issues it is recommended to wait for the next release (EMI-3 update 1)

UMD-3: Products ready for the next UMD release

emi.lfc

  • Installation Notes: There are some dependency problems (already included in the release notes) GGUS
  • Version:1.8.6

emi.bdii-site

  • Version: 1.2.0

emi.bdii-top

  • Known Issues:
    • Due to the caching mode, decommissioned services are published as 'Production' until the cache expires. Savannah BUG #99298
    • The glite-info-update-endpoints script does not fail when using the manual option and the input file does not exist. Savannah BUG #99322
  • Version: 1.1.0

emi.dpm

  • Installation Notes: There is a dependency issue with lcgdm-dav GGUS TICKET
    • Workaround: remove obsolete packages:
# yum remove emi-dpm_mysql gridsite-libs emi-version emi-dpm_disk gridsite 

and install again DPM metapackage

# yum install emi-dpm_mysql emi-dpm_disk
  • Known Issues: In some cases you may have conflicting UIDs/GIDs since uids and gids < 201 are reserved which was not mandatory in previous versions.
  • Version: 1.8.6

EMI.argus

  • Installation Notes:
    • Due to missing dependencies in the emi-argus metapackage it is needed to install fetch-crl package by hand prior to any other installation.Workaround
  • Known Issues:
    • Because SL6 uses the NSS library instead of OpenSSL, the proxy are not correctly handled this means Argus interoperabilty with WMS in SL6 is not working. GGUS TICKET
    • Argus DN with EMAILADDRESS will fail GGUS TICKET
  • Version: 1.6.0

EMI.bdii-core

  • Version: 1.5.0

EMI.canl

  • Version: 2.0.7

EMI.emi-ui

  • Installation Notes:
    • When upgrading from EMI-2 version wn there is an issue with the upgrad of voms-clients package:
# yum remove voms-clients
# yum install emi-wn
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.0.0

EMI.yaim-core

  • Version: 5.1.1

EMI.emi-wn

  • Installation Notes:
    • When upgrading from EMI-2 version wn there is an issue with the upgrad of voms-clients package:
# yum remove voms-clients
# yum install emi-wn
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version:3.0.0

EMI.glexec-wn

  • Version:1.2.0

EMI.gfal-lcg_util

  • Version:3.0.0

EMI.gsoap-gss

  • Version:3.2.0

EMI.lb

  • Installation Notes: Backward Incompatible: DB schema change. Configuration scripts update the DB automatically, manual update script provided.
  • Known Issues: Setup script may fail when unable to find messaging brokers through BDII (reporting:"glite-lb-setup: ERROR: msg, ABORT: glite-lb-setup failed!") GGUS
    • Solution: provided in the release notes
  • Version: 4.0.4

EMI.lcg-info-clients

  • Version:1.0.1

EMI.torque-wn

  • Additional Details:
    • Detailed release notes:
  • Installation Notes:
  • Known Issues:
  • Version: 1.0.0


EMI.gridsite

  • Version: 2.0.4

IGE.globus-32-bit

  • Version:5.2.4

UMD-2: General status of new updates

  • LB will be released asap to solve a problem with an log4c update released in EPEL.
  • The next release cycle of UMD-2 will start after the UMD-3 first release on May 14th.

2. Operational Issues

2.1 Updates from DMSU

no particular issue to report

2.3 UMD-2 LB issue with EPEL update

  • An update of the package log4c (from v1.2.1 to v1.2.3) in EPEL, which is not compatible, and breaks, with the LB version currently available in the UMD-2 repositories (LB v3.2.8).
    • This issue affects both SL5 and SL6 installations.
    • Upgrade of log4c lib is not recommended.
    • Ggus ticket reference
  • Developers provided a workaround which is now described in the LB known issues:
  • LB developers released in the latest EMI-2 update a fix for this issue (the same as in the workaround), which is now in the UMD software provisioning queue to be released soon as an emergency update.

2.4 EMI-3 APEL packages

The latest APEL release included in EMI-3 and currently under EGI's software provisioning process, its inclusion in UMD-3 requires special care since all the APEL components must be updated at the site level (parser and publishers) and a new central accounting database must be used. The central database is currently being tested with selected sites.

  • Do not update to the latest APEL version until both the client update and the central database have been extensively tested.
    • Do not update APEL components to EMI-3.
    • It's advisable to wait for the deployment of CREAM from EMI-3 repositories, since the installation would deploy the latest APEL clients.
  • The deployment of the EMI-3 APEL clients on an EMI-2 CREAM is not advisable.
  • A new version of APEL has been released in the latest EMI update. We would suggest to wait for the release in UMD-3 for the deployment of APEL+CREAM
    • Central repository must be confirmed to be ready for production
    • Known issues and installation notes will be released in the release notes of UMD 3.0.0

3. AOB

3.2 Next meeting

Proposed date for the next meeting is May 27th 2013, 14:00 CEST

4. Minutes