Difference between revisions of "URT:Java7"

From EGIWiki
Jump to: navigation, search
(Status of UMD services & components)
Line 109: Line 109:
 
STORM
 
STORM
 
|VOMS - can use Java 7 at runtime
 
|VOMS - can use Java 7 at runtime
STORM - TOCHECK
+
STORM - works with Java 7
 
|-
 
|-
 
|UNICORE
 
|UNICORE

Revision as of 14:52, 6 March 2015


Java 7 - as dependency of released products/components

Description of Issue

  • SL5.9:
    • JAVA 7
      • The closed-source Java 6 packages are end of life as of Feb 2013. They are not included in SL5 starting with SL5.9 . Openjdk 1.6 and 1.7 are included by TUV. It is believed that openjdk is an acceptable replacement. The closed-source packages can still be downloaded from http://java.sun.com/


Status of UMD services & components

This table lists tests answers received from the TP regading the use of Java 7.


Technology Provider Service/Component Comments
AMGA -
APEL APEL server & client (python) don't depend on Java
ARC - a dependency on java for the java API.

- use whatever is in the distribution, without any particular recommendations.

ARGUS Collaboration ZZZZ
Grid Information System don't depend on Java
CREAM cream-api-java, cream-common, cream, cream-job-plugin works with Java 7 (tested)
CREAM (S)GE module don't depend on Java
CVMFS ZZZZ
CERN Data Management DPM/LFC

FTS3

DMC clients

no dependency on Java
dCache server & srm-client all supported versions of dCache *require* Java 7 or newer. It is still avaialable a srmclient version that supports the Java 6.
UI/WN ZZZZ
EMIR ZZZZ
Frontier Squid doesn't depend on Java
gLExec-wn ees-pepd-oh ees-pepd-oh - runs within an Argus-PEPd service) using java-1.7.0-openjdk-1.7.0.65-2.5.1.2.el5_10 on a RedHat5, without any obvious problems, but no endurance testing
CESNET canl-java

L&B - java client and examples

canl-java - it is in Fedora (with java 1.8) and EPEL 7 (java 1.7)- so Java 7 is well supported

L&B java client can also work with java 1.7. We don't have testsuite for java client, but there are no known issues.

MPI mpi doesn't depend on Java
QosCosGrid [QCG] qcg-broker, qcg-broker-client working with Java version "1.7.0_65", OpenJDK Runtime Environment (IcedTea 2.5.1) (7u65-2.5.1-4ubuntu1~0.14.04.2), OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
VOMS/STORM VOMS

STORM

VOMS - can use Java 7 at runtime

STORM - works with Java 7

UNICORE unicore-unicorex, unicore-registry, unicore-gateway, unicore-xuudb,

unicore-ucc, unicore-hila

Java 7 is recommended. The versions of the products that are in UMD

still depend (via RPM manifest) on Java 6, our new releases (which are not yet in UMD) all require Java 7

WMS WMS doesn't depend on Java
Globus doesn't depend on Java