Difference between revisions of "URT:EPEL7"

From EGIWiki
Jump to: navigation, search
(Status of UMD services & components)
(Status of UMD services & components)
Line 35: Line 35:
 
| -  
 
| -  
 
| [https://admin.fedoraproject.org/pkgdb/package/nordugrid-arc/ nordugrid-arc] is available in all EPEL (5,6,7) repos
 
| [https://admin.fedoraproject.org/pkgdb/package/nordugrid-arc/ nordugrid-arc] is available in all EPEL (5,6,7) repos
 
- issue on missing dependency (https://bugzilla.redhat.com/show_bug.cgi?id=1138867), which means that ARC CE is currently not installable. The package owner is working on it.
 
 
|-
 
|-
 
|'''ARGUS Collaboration'''
 
|'''ARGUS Collaboration'''

Revision as of 15:13, 2 February 2015


Status of support of EPEL 7, together with SL7 or CentOS7

Description of Issue


Status of UMD services & components

This table lists tests answers received from the TP regading the availability fo their components in EPEL 7, SL 7 and/or CentOS 7.


Technology Provider Service/Component Comments
AMGA -
APEL APEL server & client build done for RHEL 5 & RHEL 6, no "OS" 7 for the moment
ARC - nordugrid-arc is available in all EPEL (5,6,7) repos
ARGUS Collaboration ZZZZ
Grid Information System bdii, glue-schema - available in EPEL 7
CREAM not available for or tested against EPEL 7
CREAM (S)GE module -
CVMFS ZZZZ
CERN Data Management DPM, LFC, FTS3, DMC clients All major packages are there (EPEL 7).

The building was pretty painless, once all dependencies arrived (in EPEL7) things started to work.

As for the runtime, we don't do regular testing on this platform yet, indeed we haven't announced that it's supported. We will start certifying stuff soon.

We intend to certify with plain CentOS7, not aware of any other variants out there (although CERN will produce a variant for its own use).

dCache server & srm-client dCache RPMs do not depend on anything EPEL provides, so the RPMs should work fine with EPEL 7.

The dcap RPMs do have dependencies that EPEL satisfies, v. 2.47.8-1.el7 available in EPEL7

UI/WN no tests done - if all clients are working the UI/WN should work also
EMIR ZZZZ
Frontier Squid Frontier Squid "OSG recompiles for the two OS (SL5,SL6) variants and are currently setting up their koji build system to also compile on SL7"
gLExec-wn We currently only have LCMAPS in EPEL (and Fedora) and have requested release also to EPEL7.

We can build all our software against CentOS+EPEL7 but have not yet performed any run-time testing.

CESNET caNl

GridSite

ProxyRenewal

L&B

canl-java: in EPEL 7

glite-px-proxyrenewal: in EPEL 7

canl-c: in EPEL 7

gridsite: in EPEL 7

L&B: not in EPEL7:
- classads dependency is missing (https://bugzilla.redhat.com/show_bug.cgi?id=1148415).
- but otherwise, SL7/RHEL7 is fully supported and testsuite passes

MPI no clear timeline for this activity (porting to EPEL7/OS7)
QosCosGrid [QCG] not available for or tested against EPEL 7
VOMS/STORM VOMS

STORM

tests for "OS 7"/EPEL 7 will start soon

voms, voms-api-java, voms-mysql-plugin already available in EPEL 7

UNICORE not available for or tested against EPEL 7
WMS WMS not available for or tested against EPEL 7
Globus GT6.0 available in EPEL 7 (and EPEL 5,6)