Difference between revisions of "URT:Agenda-2020-11-16"

From EGIWiki
Jump to: navigation, search
(UMD)
(VOMS)
 
(13 intermediate revisions by 4 users not shown)
Line 24: Line 24:
  
 
=== In Verification  ===
 
=== In Verification  ===
*  cream-blah 1.23.0
+
*  cream-blah 1.23.0 (failed SR)
* cvmfs 2.7.4
+
* cvmfs 2.7.5, cvmfs-config-egi-2.5, and egi-cvmfs-2-7
* egi-cvmfs 2.6.0
+
* arc6 6.8.1 (requires Xroot 5.0)
* arc6 6.8.0  
+
* xroot 5.0.2  
 
* glite-info-update-endpoints  3.0.2
 
* glite-info-update-endpoints  3.0.2
 
* apel-ssm 3.0.0
 
* apel-ssm 3.0.0
 
* ams-library 0.5.8
 
* ams-library 0.5.8
* storm  1.11.18 (1.11.17 and 1.11.16)
+
* storm  1.11.19 (centos6, centos7)
 +
* bdii 5.2.26
 +
* lcg-info 1.12.5
 +
* glite-info-update-endpoints 3.0.2
 +
* voms-admin-server 3.8.0 (centos7)
 +
* voms-clients 2.0.15
 +
* htcondor-ce 3.4.0 (UMD-5)
 +
* htcondor 8.8.11 (UMD-5)
  
 
=== Under Staged Rollout  ===
 
=== Under Staged Rollout  ===
Line 38: Line 45:
  
 
=== Ready to be Released  ===
 
=== Ready to be Released  ===
* cvmfs 2.7.3
+
* davix 0.7.6
* arc6 6.7.0
 
* xroot 4.12.3
 
* davix 0.7.6
 
* gfal2 2.18.1
 
* nagios-cream 1.2.5
 
* nagios-plugins-egi-notebooks  0.2.4
 
* nagios-probe-bdii 1.0.16
 
  
 
== CMD-OS  ==
 
== CMD-OS  ==
Line 84: Line 84:
  
 
== ARC  ==
 
== ARC  ==
6.8.1 is out in the Nordugrid repo. Not yet in EPEL stable.
+
ARC 6.9 is planned for end of November. Will contain REST interface reworked technical preview.
http://www.nordugrid.org/arc/releases/6.8.1/release_notes_6.8.1.html
 
 
 
ARC 6.8.0 and 6.8.1 is built with xrootd5. If xrootd5 is not yet in epel-stable, then if you have nordugrid-arc-plugins-xrootd installed, you must enable the epel-testing repo.
 
  
 
== CREAM  ==
 
== CREAM  ==
Line 97: Line 94:
 
== xrootd  ==
 
== xrootd  ==
  
Xrootd 5.0.2 is available in EPEL testing.
+
The '''xrootd 5.0.2''' update is available in EPEL stable since 2020-10-30.
  
Updates for all packages depending on xrootd built against xrootd 5 are also available in EPEL testing.
+
Updates for all packages in EPEL depending on xrootd built against xrootd 5 are also available in EPEL stable. Thanks to Michal Simon and Oliver Keeble for taking part in this coordinated effort.
  
 
Major changes:
 
Major changes:
Line 122: Line 119:
 
* EPEL 8: N/A (package never released for EPEL 8)
 
* EPEL 8: N/A (package never released for EPEL 8)
  
No update to xrootd 5 is planned for EPEL 6. The xrootd 4.12.4 update for EPEL 6 is in EPEL stable since September 19:
+
No update to xrootd 5 is planned for EPEL 6.
 +
 
 +
The '''xrootd 4.12.5''' update for EPEL 6 (and the corresponding update of xrootd-compat for EPEL 7) is in EPEL stable since 2020-10-31:
 +
 
 +
* EPEL 6: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-f3b7c8c8d9
 +
* EPEL 7: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d03f0f3358
  
* EPEL 6: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-2d734ca8fa
+
The '''xrootd 5.0.3''' update for EPEL 7 and EPEL 8 is in EPEL testing:
  
An xrootd 4.12.5 release is being planned, currently an RC tag exists.
+
* EPEL 7: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-c8cf316036
 +
* EPEL 8: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e4af8091d4
  
 
== caNl  ==
 
== caNl  ==
Line 137: Line 140:
  
 
v1.7.3 will be released after StoRM and VOMS releases.
 
v1.7.3 will be released after StoRM and VOMS releases.
 +
 +
Started investigation on https://ggus.eu/index.php?mode=ticket_info&ticket_id=147877
  
 
== StoRM ==
 
== StoRM ==
  
StoRM v1.11.18 released.
+
StoRM v1.11.19 released. [http://italiangrid.github.io/storm/2020/10/29/storm-v1.11.19-released.html Post] [http://italiangrid.github.io/storm/release-notes/StoRM-v1.11.19.html Release-notes]
http://italiangrid.github.io/storm/2020/08/07/storm-v1.11.18-released.html
 
  
Expected roadmap:
+
StoRM 1.11.20 not planned.
 +
We started working on Frontend's code optimization in order to avoid memory leaks.
 +
If there's no urgency on fixing some bug we'll start building and testing on CentOS 8.
  
* Release StoRM 1.11.19 with mainly an update for StoRM WebDAV by the end of this week.
+
== VOMS ==
  
== VOMS ==
+
VOMS 10-20 released. [http://italiangrid.github.io/voms/2020/10/28/voms-release-10-20.html Post]
  
Release v3.8.0 NOT yet released.
+
The updated components are:
  
Tests in progress. Got positive feedback from CERN. Expected release: by 25th of September.
+
* VOMS Admin server [http://italiangrid.github.io/voms/release-notes/voms-admin-server/3.8.0/ 3.8.0]
 +
* VOMS Admin client [http://italiangrid.github.io/voms/release-notes/voms-admin-client/2.0.20 2.0.20]
 +
* VOMS clients [http://italiangrid.github.io/voms/release-notes/voms-clients/3.3.2 3.3.2]
 +
* VOMS Java APIs [http://italiangrid.github.io/voms/release-notes/voms-api-java/3.3.2 3.3.2]
 +
* VOMS server [http://italiangrid.github.io/voms/release-notes/voms-server/2.0.15 2.0.15]
 +
* VOMS C/C++ APIs [http://italiangrid.github.io/voms/release-notes/voms-api-c/2.0.15 2.0.15]
 +
* VOMS MySQL plugin [http://italiangrid.github.io/voms/release-notes/voms-mysql-plugin/3.1.7-2 3.1.7-2]
  
Packages will be released also for CentOS 7.
+
With this release all VOMS components are now ported to CENTOS 7.
  
 
= Preview  =
 
= Preview  =

Latest revision as of 16:21, 16 November 2020

News

  • EGI repositories handover in January 2021: provider moving from IASA to IBERGRID.
    • The handover will be a complex operation due to the complexity of the repository workflows and technologies adopted. Handover preparation started with a regular meeting between IASA and IBERGRID and agreement said handover will occur in the first half of December 2020 in order to avoid the problematic end of year holiday.
    • Last released planned for November 2020.
    • During 2021 repositories will undergo a series of improvements, frontend and backend and a complete review of the procedures and workflows following a CI/CD approach.

UMD

  • UMD4 release in preparation
    • StoRM, VOMS, BDII update, dCache
    • VERY URGENT
  • feedback on software automation from the EGI Conference
  • UMD 5 dry run planned for, get the process ready for end of October
  • dedicated update for VOMS on UMD4/CentOS7 as soon as it's released
  • dedicated update for StoRM+BDII on UMD4/C7+SL6 before repo migration

CMD

Status

UMD

In Verification

  • cream-blah 1.23.0 (failed SR)
  • cvmfs 2.7.5, cvmfs-config-egi-2.5, and egi-cvmfs-2-7
  • arc6 6.8.1 (requires Xroot 5.0)
  • xroot 5.0.2
  • glite-info-update-endpoints 3.0.2
  • apel-ssm 3.0.0
  • ams-library 0.5.8
  • storm 1.11.19 (centos6, centos7)
  • bdii 5.2.26
  • lcg-info 1.12.5
  • glite-info-update-endpoints 3.0.2
  • voms-admin-server 3.8.0 (centos7)
  • voms-clients 2.0.15
  • htcondor-ce 3.4.0 (UMD-5)
  • htcondor 8.8.11 (UMD-5)

Under Staged Rollout

N/A

Ready to be Released

  • davix 0.7.6

CMD-OS

In Verification

In Staged Rollout

Ready to be released

Technical Providers - Round table

APEL

Frontier

Indigo-DataCloud

dCache

DPM/Dynafed/LFC

New version of DPM (1.13.2) available in EPEL

http://lcgdm.web.cern.ch/dmlitedpm-1132-released-epel

Data management clients

gfal2 2.17.0 pushed to EPEL

http://dmc.web.cern.ch/release/gfal2-2.17.0

FTS

New Major version of SOCI in EPEL7-testing (4.0.0). FTS rebuild needed, we are discussing with the maintainer about issues that we found.

We would need to release a new FTS build for C7 when SOCI 4 will be pushed to EPEL stable.

ARC

ARC 6.9 is planned for end of November. Will contain REST interface reworked technical preview.

CREAM

QCG

Globus

xrootd

The xrootd 5.0.2 update is available in EPEL stable since 2020-10-30.

Updates for all packages in EPEL depending on xrootd built against xrootd 5 are also available in EPEL stable. Thanks to Michal Simon and Oliver Keeble for taking part in this coordinated effort.

Major changes:

  • The old client library libXrdClient has been dropped (replacement: libXrdCl).

Minor changes:

  • The XrdSysDNS class is removed (replacement: XrdNetAddr)
  • XrdPosixXrootd::setDebug() and some other deprecated methods in that class have been dropped.

For EPEL 7 there is an xrootd-compat package providing the old xrootd 4 libraries. It is parallel installable since the sonames have changed. The compat package does not provide any devel subpackages.

Main xrootd update:

GFAL2 built against xrootd 5:

dmlite built against xrootd 5:

No update to xrootd 5 is planned for EPEL 6.

The xrootd 4.12.5 update for EPEL 6 (and the corresponding update of xrootd-compat for EPEL 7) is in EPEL stable since 2020-10-31:

The xrootd 5.0.3 update for EPEL 7 and EPEL 8 is in EPEL testing:

caNl

BDII

WN/UI

Argus

v1.7.3 will be released after StoRM and VOMS releases.

Started investigation on https://ggus.eu/index.php?mode=ticket_info&ticket_id=147877

StoRM

StoRM v1.11.19 released. Post Release-notes

StoRM 1.11.20 not planned. We started working on Frontend's code optimization in order to avoid memory leaks. If there's no urgency on fixing some bug we'll start building and testing on CentOS 8.

VOMS

VOMS 10-20 released. Post

The updated components are:

With this release all VOMS components are now ported to CENTOS 7.

Preview

  • released on 2020-10-09
    • Preview 1.29.0 AppDB info (sl6): ARC 6.8.0 and 6.8.1, BDII 5.5.26, CVMFS 2.7.4, dCache 5.2.31, DMLite/DPM 1.14.0, frontier-squid 4.13.1, glite-info-update-endpoints 3.0.2, lcg-info 1.12.5, STORM 1.11.18
    • Preview 2.29.0 AppDB info (CentOS 7): ARC 6.8.0 and 6.8.1, BDII 5.5.26, CVMFS 2.7.4, dCache 5.2.31, DMLite/DPM 1.14.0, frontier-squid 4.13.1, glite-info-update-endpoints 3.0.2, lcg-info 1.12.5, STORM 1.11.18

UMD on CentOS 8

  • Plan to be defined with
    • Technical Providers
    • WLCG
    • NGIs/sites (there was 1 request so far)
    • UMD team (innovation in the process must be taken into consideration)

Wiki: https://wiki.egi.eu/wiki/Next_middleware_release

AOB

ARC finds it problematic that the ARC released in UMD is always so far behind the current newest release. We are considering to stop providing ARC for UMD.

The verification procedure for ARC - does it involve running ARC together with other relevant packages in the release to make sure compatibility is met?