Difference between revisions of "UMD-2:UMD-2.2.0"

From EGIWiki
Jump to: navigation, search
Line 28: Line 28:
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/cream-sge-module CREAM SGE Module release notes]
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/cream-sge-module CREAM SGE Module release notes]
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
*'''Known Issues:''' No additional issues found during EGI's Software Provisioning.
+
*'''Known Issues:'''
 +
**Bug in glite-info-dynamic-sge: https://ggus.eu/ws/ticket_info.php?ticket=83352
 +
**Workaround
 +
(1)
 +
In line 264
 +
print_glue_data("glue2-static-file-computing-manager", @{@ManagerDNs});
 +
should read
 +
print_glue_data("glue2-static-file-computing-manager", @ManagerDNs);
 +
otherwise the error
 +
"Can't use string ("1") as an ARRAY ref while "strict refs" in use at /usr/libexec/glite-info-dynamic-sge  line 264." appears in bdii-update.log
 +
(2) line 402 has a missing "\n"
 +
( should be printf( "%s\n", $dn ); )
 
*'''Version:''' 2.0.0
 
*'''Version:''' 2.0.0
  
Line 44: Line 55:
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/glite-proxyrenewal-1 EMI-MyPROXY and gLite-proxyrenewal release notes
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/glite-proxyrenewal-1 EMI-MyPROXY and gLite-proxyrenewal release notes
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
*'''Known Issues:''' No additional issues found during EGI's Software Provisioning.  
+
*'''Known Issues:'''
 +
**default configuration change, introduces backward incompatibility: https://ggus.eu/tech/ticket_show.php?ticket=86527
 +
**Workaround: In EMI PX Server (emi-px-1.0.1-1.el5) self authorization is not allowed by defaul.
 +
We had to add the following option to /etc/myproxy-server.config, and restart the service allow_self_authorization true
 
*'''Version:''' 1.0.1
 
*'''Version:''' 1.0.1
  
Line 102: Line 116:
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/cream-sge-module CREAM SGE Module release notes]
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/cream-sge-module CREAM SGE Module release notes]
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
*'''Known Issues:''' No additional issues found during EGI's Software Provisioning.
+
*'''Known Issues:'''
 +
**Bug in glite-info-dynamic-sge: https://ggus.eu/ws/ticket_info.php?ticket=83352
 +
**Workaround
 +
(1)
 +
In line 264
 +
print_glue_data("glue2-static-file-computing-manager", @{@ManagerDNs});
 +
should read
 +
print_glue_data("glue2-static-file-computing-manager", @ManagerDNs);
 +
otherwise the error
 +
"Can't use string ("1") as an ARRAY ref while "strict refs" in use at /usr/libexec/glite-info-dynamic-sge  line 264." appears in bdii-update.log
 +
(2) line 402 has a missing "\n"
 +
( should be printf( "%s\n", $dn ); )
 
*'''Version:''' 2.0.0
 
*'''Version:''' 2.0.0
  
Line 118: Line 143:
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/glite-proxyrenewal-1 EMI-MyPROXY and gLite-proxyrenewal release notes
 
**Detailed release notes: [http://www.eu-emi.eu/emi-2-matterhorn-products/-/asset_publisher/B4Rk/content/glite-proxyrenewal-1 EMI-MyPROXY and gLite-proxyrenewal release notes
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
 
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
*'''Known Issues:''' No additional issues found during EGI's Software Provisioning.  
+
*'''Known Issues:'''
*'''Version:'''
+
**default configuration change, introduces backward incompatibility: https://ggus.eu/tech/ticket_show.php?ticket=86527
 +
**Workaround: In EMI PX Server (emi-px-1.0.1-1.el5) self authorization is not allowed by defaul.
 +
We had to add the following option to /etc/myproxy-server.config, and restart the service allow_self_authorization true
 +
*'''Version:''' 1.0.1
  
 
== emi.bdii-core.sl5.x86  ==
 
== emi.bdii-core.sl5.x86  ==

Revision as of 16:44, 7 October 2012

UMD 2.2.0 : Additional information for provided products

While undergoing the EGI Software Provisioning process, some installation issues and known problems were detected and documented. This document provides the same information, in one single place, where site admins may learn about the provided software prior to installation or, with later updates to UMD-2, upgrading their systems.

Each section that follows will be linked by the relevant sections provided in the EGI Software Repository for this release of UMD.

Scientific Linux 6

emi.mpi.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.3.0

emi.argus.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.5.0

emi.cream-sge.sl6.x86

(1)
In line 264
print_glue_data("glue2-static-file-computing-manager", @{@ManagerDNs});
should read
print_glue_data("glue2-static-file-computing-manager", @ManagerDNs);
otherwise the error
"Can't use string ("1") as an ARRAY ref while "strict refs" in use at /usr/libexec/glite-info-dynamic-sge  line 264." appears in bdii-update.log
(2) line 402 has a missing "\n"
( should be printf( "%s\n", $dn ); )
  • Version: 2.0.0

emi.unicore-uvos.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.5.1-1

emi.myproxy.sl6.x86

We had to add the following option to /etc/myproxy-server.config, and restart the service allow_self_authorization true

  • Version: 1.0.1

emi.bdii-core.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.4.0

emi.gridsite.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.7.22

emi.trustmanager.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 3.1.4

emi.gfal-lcg_util.sl6.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.13.0

Scientific Linux 5

emi.mpi.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.3.0

emi.argus.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.5.0

emi.cream-sge.sl5.x86

(1)
In line 264
print_glue_data("glue2-static-file-computing-manager", @{@ManagerDNs});
should read
print_glue_data("glue2-static-file-computing-manager", @ManagerDNs);
otherwise the error
"Can't use string ("1") as an ARRAY ref while "strict refs" in use at /usr/libexec/glite-info-dynamic-sge  line 264." appears in bdii-update.log
(2) line 402 has a missing "\n"
( should be printf( "%s\n", $dn ); )
  • Version: 2.0.0

emi.unicore-uvos.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.5.1-1

emi.myproxy.sl5.x86

We had to add the following option to /etc/myproxy-server.config, and restart the service allow_self_authorization true

  • Version: 1.0.1

emi.bdii-core.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.4.0

emi.gridsite.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.7.22

emi.trustmanager.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 3.1.4

emi.gfal-lcg_util.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.13.0

emi.lb.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 3.2.7

ige.globus-default-security.sl5.x86

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 5.2.1

ige.security-integration.sl5.x86

  • Additional Details:
    • Detailed release notes: Globus Toolkit and SCAS client backends for LCAS/LCMAPS
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 2.2.0

ige.globus-myproxy.sl5.x86

  • Additional Details:
    • Detailed release notes: For information specific to the RPM packaged version of the software see the file /usr/share/doc/myproxy-server-5.6/README.Fedora
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 5.6.3

Debian 6

emi.unicore-uvos.debian-squeeze.amd64

  • Additional Details:
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No additional issues found during EGI's Software Provisioning.
  • Version: 1.5.1-1