Difference between revisions of "UMD-1 UMD-1.4.0"

From EGIWiki
Jump to: navigation, search
Line 9: Line 9:
 
== emi.mpi.sl5.x86_64  ==
 
== emi.mpi.sl5.x86_64  ==
  
*'''Additional Details:''' No issues found during EGI's Software Provisioning.
+
*'''Additional Details:'''
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-8-14-10-2011  
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-8-14-10-2011  
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
+
*'''Installation Notes:'''
*'''Known Issues:'''
+
*'''Known Issues:'''  
 
**Maui versions prior to 3.3.4 do not allocate correctly all the nodes, this batch system issue affects to MPI jobs. GGUS tickets:  
 
**Maui versions prior to 3.3.4 do not allocate correctly all the nodes, this batch system issue affects to MPI jobs. GGUS tickets:  
 
***https://ggus.eu/ws/ticket_info.php?ticket=57828  
 
***https://ggus.eu/ws/ticket_info.php?ticket=57828  
 
***https://ggus.eu/ws/ticket_info.php?ticket=6787  
 
***https://ggus.eu/ws/ticket_info.php?ticket=6787  
**/opt/glite/yaim/bin/yaim -c -s site-info.def -n MPI_CE -n creamCE -n TORQUE_server -n TORQUE_utils.
+
**/opt/glite/yaim/bin/yaim -c -s site-info.def -n MPI_CE -n creamCE -n TORQUE_server -n TORQUE_utils.  
***The placing of "-n MPI_CE" at the start is important.
+
***The placing of "-n MPI_CE" at the start is important.  
**Extra steps requited for MPI_SSH_HOST_BASED_AUTH=yes
+
**Extra steps requited for MPI_SSH_HOST_BASED_AUTH=yes  
***On each worker node:
+
***On each worker node:  
***/etc/ssh/sshd_config required changes on WN and needed to: cp /etc/edg-pbs-shostsequiv.conf.template /etc/edg-pbs-shostsequiv.conf
+
***/etc/ssh/sshd_config required changes on WN and needed to: cp /etc/edg-pbs-shostsequiv.conf.template /etc/edg-pbs-shostsequiv.conf  
***edit /etc/edg-pbs-shostsequiv.conf, set: NODES       = . Then run the command: /usr/sbin/edg-pbs-shostsequiv
+
***edit /etc/edg-pbs-shostsequiv.conf, set: NODES = . Then run the command: /usr/sbin/edg-pbs-shostsequiv  
 
**OSC mpiexec is an optional install from source. Do not use OSC mpiexec with OpenMPI. OSC mpiexec works well with mpich2.
 
**OSC mpiexec is an optional install from source. Do not use OSC mpiexec with OpenMPI. OSC mpiexec works well with mpich2.
  
 
*'''Version:''' 1.1.0
 
*'''Version:''' 1.1.0
  
<br>
+
<br>  
  
 
== emi.storm.sl5.x86_64  ==
 
== emi.storm.sl5.x86_64  ==
Line 40: Line 40:
 
== emi.apel.sl5.x86_64  ==
 
== emi.apel.sl5.x86_64  ==
  
*'''Additional Details:''' No issues found during EGI's Software Provisioning.
+
*'''Additional Details:'''
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#APEL_publisher_v_3_2_8_task_2390  
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#APEL_publisher_v_3_2_8_task_2390  
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
+
*'''Installation Notes:'''  
 
*'''Known Issues:''':  
 
*'''Known Issues:''':  
 
**yaim execution gives an error: mysqladmin: CREATE DATABASE failed; error: 'Can't create database 'accounting'; database exists  
 
**yaim execution gives an error: mysqladmin: CREATE DATABASE failed; error: 'Can't create database 'accounting'; database exists  
Line 52: Line 52:
 
****---  
 
****---  
 
****&gt; if [&nbsp;! $? = 0 ]; then  
 
****&gt; if [&nbsp;! $? = 0 ]; then  
**Problem with file /usr/bin/apel-publisher_tmp from glite-apel-publisher-2.0.16-0.sl5. Variable MYSQL_DRIVER_CP does not contain file /usr/share/glite-apel-core/java/mm-mysql.jar
+
**Problem with file /usr/bin/apel-publisher_tmp from glite-apel-publisher-2.0.16-0.sl5. Variable MYSQL_DRIVER_CP does not contain file /usr/share/glite-apel-core/java/mm-mysql.jar  
***https://ggus.eu/tech/ticket_show.php?ticket=77129
+
***https://ggus.eu/tech/ticket_show.php?ticket=77129  
***Adding the jar file (from glite-apel-core-2.0.14-4.sl5) to MYSQL_DRIVER_CP fixes the problem.
+
***Adding the jar file (from glite-apel-core-2.0.14-4.sl5) to MYSQL_DRIVER_CP fixes the problem.  
 
*'''Version:''' 3.2.8
 
*'''Version:''' 3.2.8
  
<br>
+
<br>  
  
 
== emi.ge-utils.sl5.x86_64  ==
 
== emi.ge-utils.sl5.x86_64  ==
  
*'''Additional Details:''' No issues found during EGI's Software Provisioning.
+
*'''Additional Details:'''  
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#BLAH_v_1_16_3_task_22845  
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#BLAH_v_1_16_3_task_22845  
*'''Installation Notes:''' No issues found during EGI's Software Provisioning.
+
*'''Installation Notes:'''
*'''Known Issues:'''
+
*'''Known Issues:'''  
**The file /var/lib/bdii/gip/plugin/glite-info-dynamic-scheduler-wrapper is incorrectly generated:
+
**The file /var/lib/bdii/gip/plugin/glite-info-dynamic-scheduler-wrapper is incorrectly generated:  
 
***https://ggus.eu/ws/ticket_info.php?ticket=76961  
 
***https://ggus.eu/ws/ticket_info.php?ticket=76961  
***In the /etc/blah.conf file it is needed to uncomment the line with the sge_helperpath (reported as known issue by TP).
+
***In the /etc/blah.conf file it is needed to uncomment the line with the sge_helperpath (reported as known issue by TP).  
 
*'''Version:''' 1.0.0
 
*'''Version:''' 1.0.0
  
<br>
+
<br>  
  
 
== emi.cream.sl5.x86_64  ==
 
== emi.cream.sl5.x86_64  ==
  
*'''Additional Details:''' No issues found during EGI's Software Provisioning.
+
*'''Additional Details:'''
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#CREAM_v_1_13_3_task_2402  
 
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#CREAM_v_1_13_3_task_2402  
*'''Installation Notes:'''
+
*'''Installation Notes:'''  
**A very minor bug was found in the yaim plugin for the cream, but it has no implications on the functionality or configuration:
+
**A very minor bug was found in the yaim plugin for the cream, but it has no implications on the functionality or configuration:  
 
***GGUS: https://ggus.eu/ws/ticket_info.php?ticket=76966  
 
***GGUS: https://ggus.eu/ws/ticket_info.php?ticket=76966  
 +
*'''Known Issues:'''
 +
**During yaim execution for EMI CREAM, when variable CE_OTHERDESCR contains space:
 +
***https://ggus.eu/tech/ticket_show.php?ticket=77117
 +
****/opt/glite/yaim/functions/config_cream_gip_glue2: line 192: [: Cores=2,: unary operator expected
 +
****It is caused by line:
 +
****if [ `echo $CE_OTHERDESCR | grep Benchmark` &gt; /dev/null ]; then
 +
****adding " before first ` and after second ` should fix this problem:
 +
****if [ "`echo "$CE_OTHERDESCR" | grep Benchmark`" &gt; /dev/null ]; then
 +
*'''Version:''' 1.13.3
 +
 +
<br>
 +
 +
== emi.lcg-util.sl5.x86_64 ==
 +
 +
*'''Additional Details:''' No issues found during EGI's Software Provisioning.
 +
**Detailed release notes: http://www.eu-emi.eu/emi-1-kebnekaise-updates/-/asset_publisher/Ir6q/content/update-10-24-11-2011#GFAL_lcg_util_v_1_11_19_task_225
 +
*'''Installation Notes:'''  No issues found during EGI's Software Provisioning.
 
*'''Known Issues:''' No issues found during EGI's Software Provisioning.  
 
*'''Known Issues:''' No issues found during EGI's Software Provisioning.  
**During yaim execution for EMI CREAM, when variable CE_OTHERDESCR contains space:
+
*'''Version:''' 1.11.19
***https://ggus.eu/tech/ticket_show.php?ticket=77117
 
****  /opt/glite/yaim/functions/config_cream_gip_glue2: line 192: [: Cores=2,: unary operator expected
 
****It is caused by line:
 
****  if [ `echo $CE_OTHERDESCR | grep Benchmark` > /dev/null ]; then
 
****adding " before first ` and after second ` should fix this problem:
 
**** if [ "`echo "$CE_OTHERDESCR" | grep Benchmark`" > /dev/null ]; then
 
*'''Version:''' 1.13.3
 
  
<br>
+
<br>  
  
 
== ige.globus-default-security.sl5.x86_64  ==
 
== ige.globus-default-security.sl5.x86_64  ==

Revision as of 15:05, 15 December 2011

UMD 1.4.0 : Additional information for provided products

While undergoing the EGI Software Provisioning process, some installation issues and known problems were detected and documented. This document provides the same information, in one single place, where site admins may learn about the provided software prior to installation or, with later updates to UMD -1, upgrading their systems.

Each section that follows will be linked by the relevant sections provided in the EGI Software Repository for this release of UMD.


emi.mpi.sl5.x86_64

  • Additional Details:
  • Installation Notes:
  • Known Issues:
    • Maui versions prior to 3.3.4 do not allocate correctly all the nodes, this batch system issue affects to MPI jobs. GGUS tickets:
    • /opt/glite/yaim/bin/yaim -c -s site-info.def -n MPI_CE -n creamCE -n TORQUE_server -n TORQUE_utils.
      • The placing of "-n MPI_CE" at the start is important.
    • Extra steps requited for MPI_SSH_HOST_BASED_AUTH=yes
      • On each worker node:
      • /etc/ssh/sshd_config required changes on WN and needed to: cp /etc/edg-pbs-shostsequiv.conf.template /etc/edg-pbs-shostsequiv.conf
      • edit /etc/edg-pbs-shostsequiv.conf, set: NODES = . Then run the command: /usr/sbin/edg-pbs-shostsequiv
    • OSC mpiexec is an optional install from source. Do not use OSC mpiexec with OpenMPI. OSC mpiexec works well with mpich2.
  • Version: 1.1.0


emi.storm.sl5.x86_64


emi.apel.sl5.x86_64


emi.ge-utils.sl5.x86_64


emi.cream.sl5.x86_64


emi.lcg-util.sl5.x86_64


ige.globus-default-security.sl5.x86_64

  • Additional Details: No issues found during EGI's Software Provisioning.
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 5.0.5


ige.globus-gridftp.sl5.x86_64

  • Additional Details: No issues found during EGI's Software Provisioning.
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 5.0.5


ige.globus-rls.sl5.x86_64

  • Additional Details: No issues found during EGI's Software Provisioning.
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 5.0.5


ige.globus-gsissh.sl5.x86_64

  • Additional Details: No issues found during EGI's Software Provisioning.
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 4.3.3


ige.globus-myproxy.sl5.x86_64

  • Additional Details: No issues found during EGI's Software Provisioning.
  • Installation Notes: No issues found during EGI's Software Provisioning.
  • Known Issues: No issues found during EGI's Software Provisioning.
  • Version: 5.4.4