Software Calendars

From EGIWiki
Revision as of 18:52, 7 May 2015 by Caifti (talk | contribs) (Decommissioning Calendar dCache 2.6.X)
Jump to: navigation, search
Main EGI.eu operations services Support Documentation Tools Activities Performance Technology Catch-all Services Resource Allocation Security


Middleware menu: Home Software Calendars Technology Providers UMD Release Schedule UMD Products Overview UMD Products ID Cards Release and deployment process Middleware Requirements Next middleware release



This page provides an overview of the timing and operations steps for the retirement of grid middleware that either already reached end of security updates and support or that is about to reach this status.

dCache v. 2.6.x

Support calendar dCache v.2.6.x

End of Support for dCache v. 2.6.X: May 2015.

Decommissioning Calendar dCache 2.6.X

The dCache 2.6.X decommissioning deadline is 21-09-2015. Details:

  • 31-08-2015: dCache 2.6.X 2 version monitoring probes start returning CRITICAL, alarms are displayed in the Operations Dashboard
  • 21-09-2015: dCache 2.6.X decommissioning deadline - after this date all the dCache 2.6.X services must be decommissioned, upgraded to a supported version or in downtime.

Operations Calendar dCache v. 2.6.X

  • From 31-08-2015: Nagios probes will detected unsupported service end-points according to the version information available from BDII. Probes detecting unsupported service end-points, will generate alarms that can be tracked by administrators on the site operations dashboard site operations dashboard.
    • Site managers of Resource Centres found to be hosting dCache v. 2.6.X, will be contacted through GGUS by ROD to request the retirement/upgrade of the affected products. They should provide upgrade plans within 10 working days from the day the ticket is received
  • Monitoring probe: eu.egi.sec.dCache-2.6 documentation will be upgraded soon

dCache v. 2.2.X

Support Calendar dCache v. 2.2.X

End of Support for dCache v. 2.2.X - July 2014, once hte new golden-release (2.10.X) is made available, according to Official dCache Releases & Release Policy page

Decommissioning Calendar dCache 2.2.X

The dCache 2.2.X decommissioning deadline is 31-10-2014.

Details:

  • on 22-09-2014: dCache 2.2.X 2 version monitoring probes start returning CRITICAL, alarms are displayed in the Operations Dashboard
  • 31-10-2013: dCache 2.2.X decommissioning deadline after this date all the dCache 2.2.X services must be decommissioned, upgraded to a supported version or in downtime.

Operations Calendar dCache v. 2.2.X

  • From 22-09-2014 Nagios probes (run by a dedicated EGI instance of SAM) will detected unsupported service end-points according to the version information available from BDII. Probes detecting unsupported service end-points, will generate alarms that can be tracked by administrators on the site operations dashboard.
    • Site managers of Resource Centres found to be hosting dCache v. 2.2.X, will be contacted through GGUS by ROD to request the retirement/upgrade of the affected products. They should provide upgrade plans within 10 working days from the day the ticket is received
  • Monitoring probe: eu.egi.sec.dCache-2.2 documentation will be upgraded soon

EMI 2

Text below applies to all EMI 2 products.

Support Calendar EMI2

End of security updates and support: 30-04-2014 (Official EMI page)

Decommissioning Calendar EMI2

The EMI 2 decommissioning deadline is 31-05-2014.

Details:

  • by 01-03-2014: new EMI 2 version probes are tested returning WARNING
  • on 03-03-2014: EMI 2 version monitoring probes start returning CRITICAL, alarms are displayed in the Operations Dashboard
  • 30-04-2014: end of security updates and support of EMI 2
  • 31-05-2013: EMI 2 decommissioning deadline after this date all the EMI-2 services must be decommissioned, upgraded to a supported version or in downtime.

Affected middleware version

  • ARC v2.*
  • ARGUS v1.5.*
  • BDII Site older than v1.2.0
  • BDII Top older than v1.1.0
  • CREAM v1.14.*
  • dCache v2.2.*
  • DPM older than v1.8.6
  • EMI-UI v2.*
  • EMI-WN v2.*
  • FTS v.2.2.8
  • StoRM older than v.1.11.0
  • VOMS v.2.*

Operations Calendar EMI2

  • From 03-03-2014 Nagios probes (run by a dedicated EGI instance of SAM) will detected unsupported service end-points according to the version information available from BDII - where possible. Probes detecting unsupported service end-points, will generate alarms that can be tracked by administrators on the site operations dashboard.
  • After 03-03-2014 administrators of the affected Resource Centres will receive notification tickets, and will be requested to provide information about their upgrade plans within 10 working days from the day the ticket is received.

(EMI 1) StoRM v. 1.8.3

Support Calendar

StoRM 1.11.1 was released in UMD-3. StoRM 1.8.3 security support ends on July 15 2013.

End of security updates of StoRM was scheduled after three weeks of the complete and successful process of staged rollout for a version of StoRM for UMD-3.

Decommissioning Calendar

StoRM 1.8.3 or older versions must be upgraded to a supported release within one month after the end of security support of the EMI-1 version 1.8.3.

The current version of StoRM available in UMD-3 (v.1.11.1) has performance issues, and currently the installation of this version is discouraged. Without a replacement for the EMI-1 version, the deadline for the decommission of EMI-1 StoRM is currently not fixed. It will be updated once the patch is available in UMD.

Monitoring tests which identify StoRM production instances which reach end of support are now raising warnings in the midmon nagios instance.

(EMI 1) dCache v. 1.9.12

Support Calendar

End of Security Updates and Support of dCache v. 1.9.12 is scheduled on 31-09-2013. dCache v. 1.9.12 is part of the EMI-1 release, and the end of Security Updates and Support was previously scheduled on 30-04-2013. Security Updates and Support only provides updates targeting security vulnerabilities. dCache v. 1.9.12 will not get SHA2 support back-ported. EGI and dCache.org will make a separate announcement on the roadmap for SHA2 support in dCache.

Decommissioning Calendar

dCache v. 1.9.12 must be upgraded/retired by 30-09-2013 and no later than 30-10-2013 in compliance to the EGI Service Operations Security Policy (https://documents.egi.eu/document/669).

Operations Calendar dCache v. 1.9.12

  • From 01-07-2013 site managers of Resource Centres found to be hosting dCache v. 1.9.12, will be contacted through GGUS by ROD to request the retirement of the affected products.
  • Monitoring probe: eu.egi.sec.dCache-EMI-1 (see documentation)

EMI 1

Text below applies to all EMI 1 products with the exception of dCache 1.9.12.

Support Calendar EMI1

End of security updates and support: 30-04-2013 (http://www.eu-emi.eu/releases#MajRel)

Decommissioning Calendar EMI1

The EMI 1 decommissioning deadline is 01-05-2013.

Details:

  • by 31-12-2013: new EMI 1 version probes are tested
  • on 01-01-2013: EMI 1 version monitoring probes start returning WARNING
  • on 01-03-2013: EMI 1 version monitoring probes start returning CRITICAL, alarms are displayed in the Operations Dashboard
  • 30-04-2013: end of security updates and support of EMI 1
  • 01-05-2013: EMI 1 decommissioning deadline

Operations Calendar EMI1

  • From 01-03-2013 Nagios probes (run by a dedicated EGI instance of SAM) will detected unsupported service end-points according to the version information available from BDII - where possible. Probes detecting unsupported service end-points, will generate alarms that can be tracked by administrators on the site operations dashboard.
  • After 01-03-2013 administrators of the affected Resource Centres will receive notification tickets, and will be requested to provide information about their upgrade plans within 10 working days from the day the ticket is received.

gLite 3.1 and gLite 3.2 products

Support Calendar gLite

The gLite 3.1 distribution is now no longer supported (http://glite.cern.ch/R3.1/) and SL4 reached end of security support on 02/02/2012.

The follorwing gLite 3.2 components are out of security support: APEL, ARGUS, BDII, Cluster, CREAM, dCache, LB, LSF utils, MPI utils, SCAS, SGE utils, Torque client/server/utils, VOMS (http://glite.cern.ch/R3.2/) .

Decommissioning Calendar gLite

The products must be retired by 30-09-2012

Operations Calendar gLite


  • From 01-10-2012 site managers of Resource Centres found to be hosting unsupported gLite 3.1/3.2 services, will be contacted through GGUS by the Central Grid Oversight team to request the retirement of the affected products.
  • From 01-11-2012 Resource Centres that will fail to retire unsupported gLite software, do not put the affected service end points in scheduled downtime, and do not provide information about their upgrade plans will be eligible for suspension and the problem will be escalated to EGI CSIRT.

gLite 3.2 WN, DPM, LFC and dCache

Support Calendar gLite3.2

These products are now all unsupported (http://glite.cern.ch/R3.2/):

  • glite-SE_dcache (end of security updates and support: 31/10/2011)
  • glite-WN, glite-SE_dpm and glite-LFC (end of security updates and support: 30/11/2012).

Decommissioning Calendar gLite3.2

The services listed above must be decommissioned by 31-01-2013

Service end-points which can not be upgraded by this deadline, must be set in downtime as of 01-02-2013, unless upgrading is not possible for technical reasons.

Operations Calendar gLite3.2

  • Deployment of unsupported end-points is tracked by the EGI dashboard
  • From the first week of December Nagios probes (run by a dedicated EGI instance of SAM) will detected unsupported service end-points according to the version information available from BDII. Probes detecting unsupported service end-points, will generate alarms that can be tracked by administrators on the site operations dashboard
  • Administrators of the affected Resource Centres will receive notification tickets, and are requested to provide information about their upgrade plans within 10 working days from the day the ticket is received.


Retired software

gLite 3.1 and 3.2 are both retired with the only exception of glite-VOBOX for which only Security Updates are granted until 30/04/2013.

Provider Release Notes/Updates Support calendar Release plan Information
Latest releases Release Schedule
gLite3.2 patches under development

EMI 3 Monte Bianco

EMI 2 Matterhorn

EMI-1 Kebnekaise

EMI Support Calendar

EMI Support Policy EMI Release Policy

EMI Incident Handling Policy


Release notes

IGE support calendar (file)
Instructions to submit requirement to IGE

IGE Requirements