Difference between revisions of "Agenda-02-02-2015"

From EGIWiki
Jump to: navigation, search
(Created page with "{| |- | [http://connect.ct.infn.it/egi-inspire-sa1-ter/ '''Adobe connect''' direct link] | ''Conference system is on adobe connect, no password required. |} {{TOC right}} = U...")
 
(Blanked the page)
 
Line 1: Line 1:
{|
 
|-
 
| [http://connect.ct.infn.it/egi-inspire-sa1-ter/ '''Adobe connect''' direct link]
 
| ''Conference system is on adobe connect, no password required.
 
|}
 
 
{{TOC right}}
 
  
= UMD releases status =
 
 
== Status of the products verification/staged rollout ==
 
 
 
=== Released ===
 
* Last release UMD
 
 
=== Under Staged Rollout ===
 
 
 
* cream-torque v. 2.1.4
 
 
* glexec-wn v. 1.3.0
 
 
 
=== In Verification ===
 
 
* cream-ge v. 2.3.0
 
* qcg-computing-3.4.0 (only SL6)
 
* qcg-notifications-3.4.0 (only SL6)
 
* squid v. 2.7.19
 
* fts3 v. 3.2.27
 
* apel v. 1.3.1
 
* px v. 1.3.36
 
* wms-ice v. 3.5.4
 
* Globus 6.0.0 products: Gridftp, Globus-Default-Security, Gram5, MyProxy;
 
 
'''Ready to be released:'''
 
 
* CREAM v. 1.16.4
 
* DPM 1.8.9
 
* F.SQUID v. 2.7.19-21
 
* FTS3 v. 3.2.30
 
* VOMS clients v. 3.0.5/3.0.6
 
* Voms Admin v. 2.0.12
 
 
=== Rejected ===
 
 
* -----
 
 
== Timeline for the next UMD updates ==
 
* End Jan
 
*
 
 
= Updates from the product teams =
 
This section is directly contributed by the product teams. Please, add under your section the scheduled releases with a short comment about the updates introduced and where they are going to be released (EMI repositories, EPEL, private repositories ecc), linking external pages with these information is ok, but please add at least the expected date of the next release. It is important to discuss, within the URT, changes that may affect directly or indirectly other products. The text will be copied into the agenda of the next URT meeting, PT will just need to check that all the information are up to date.
 
Please, feel free to alter the template if it doesn't feet with your needs.
 
 
== APEL ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== ARC ==
 
* Release version 5.0.0 Expected: 2015-01-yy
 
** Main changes: (including other products affected)
 
*** Removal of old components:
 
**** arc-ur-logger (replaced with Jura)
 
**** LFC DMC
 
**** DQ2 DMC
 
**** old data staging
 
**** Confusa (abandoned prototype)
 
**** arcmigrate cli tool
 
**** arcslcs
 
**** SAML service
 
**** gridsite dependency
 
** Other information:
 
 
== Argus ==
 
* Release version w.k.j Expected on: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== dCache ==
 
* Release version 2.6.38 Expected: next UMD release
 
** Main changes: see appdb
 
** Other information:
 
 
== BDII ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== DPM/LFC ==
 
* DPM
 
** DPM/LFC 1.8.9 - in EPEL stable
 
** https://svnweb.cern.ch/trac/lcgdm/blog/dpm_1.8.9_relnotes
 
** a fix for a bug on the latest dmlite component part of DPM 1.8.9 has been released and and it's already in EPEL stable
 
** https://svnweb.cern.ch/trac/lcgdm/attachment/wiki/Dpm/dmlite0.7.2-relnotes.txt
 
** First tests with CentOS7 using components from EPEL7, some issues found, but most of the components are working out of the box
 
 
== GFAL/lcg_utils ==
 
* The CERN Data Management Clients publish their releases here: http://dmc.web.cern.ch/releases
 
* A new page with all releases and they status is available at https://dmc-docs.web.cern.ch/dmc-docs/
 
* New in EPEL
 
** gfal2 2.7.8
 
** gfal2-python 1.6.0
 
** gfal2-util 1.1.0
 
** srm-ifce 1.20.14
 
** CGSI-gSOAP 1.3.7
 
 
* CERN-PROD is available for staged rollout
 
 
== FTS ==
 
* FTS3 - v. 3.2.30 in EPEL-stable
 
 
==  Frontier-Squid ==
 
* Release version: 2.7STABLE9-21.1; Released: 2014-12-03 -
 
** Main changes: http://frontier.cern.ch/dist/rpms/frontier-squidRELEASE_NOTES
 
*** Mainly improves multiple squid support, increasing max from 4 to 16 squids and limiting each squid to a share of available file descriptors
 
** Other information (repository): http://frontier.cern.ch/dist/rpms
 
 
== EMIR  ==
 
* Release version: ; Expected:
 
** Main changes:
 
** Other information:
 
 
== UNICORE ==
 
(expected in the course of 2015 that we will publish packages for UMD via AppDB at https://appdb.egi.eu/store/software/unicore
 
 
For now, packages for UNICORE 7.2.0 can be downloaded from
 
 
Debian:
 
http://unicore-dev.zam.kfa-juelich.de/release-candidates/core/7.2.0-packages/deb
 
 
RPM:
 
http://unicore-dev.zam.kfa-juelich.de/release-candidates/core/7.2.0-packages/rpm
 
 
RPM packages were tested on Centos 6, so SL6 will be fine. SL5 is NOT supported
 
any more.
 
 
Changes are listed with respect to the last UNICORE version available in UMD
 
which is 6.6.0
 
 
* UNICORE/X 7.2.0 (expected on: 2015-01-21)
 
** Main changes: (including other products affected)
 
*** Product name is "unicore-unicorex"
 
*** New web services stack based on Apache CXF and Apache HTTPClient 4
 
*** RESTful API in addition to the SOAP/WS API
 
*** Many performance improvements
 
*** Many fixes for bugs and some security vulnerabilities (e.g. SSL POODLE)
 
*** For a full, detailed list of changes please refer to http://unicore.eu/changes/server.html
 
** Other information:
 
*** This is a major update. We recommend uninstalling any older (6.6) version that you may have, and re-install from scratch.
 
*** UNICORE 7 is backwards compatible with UNICORE 6
 
*** HTML doc http://unicore.eu/documentation/manuals/unicore6/files/unicorex/unicorex-manual.html
 
*** PDF doc http://unicore.eu/documentation/manuals/unicore6/files/unicorex/unicorex-manual.pdf
 
 
* TSI 7.2.0 (expected on: 2015-01-21)
 
** Main changes: (including other products affected)
 
*** There are now individual packages for the different supported batch systems
 
*** Product names are "unicore-tsi-nobatch", "unicore-tsi-torque", "unicore-tsi-lsf", "unicore-tsi-sge" and "unicore-tsi-slurm"
 
*** Several bug fixes
 
*** Improved support for SSL (e.g. when using IPv6, better error messages)
 
*** For a full, detailed list of changes please refer to http://unicore.eu/changes/server.html
 
** Other information:
 
*** This is a major update. We recommend uninstalling any older (6.6) version that you may have, and re-install from scratch.
 
*** UNICORE 7 is backwards compatible with UNICORE 6
 
*** HTML doc http://unicore.eu/documentation/manuals/unicore6/files/tsi/tsi-manual.html
 
*** PDF doc http://unicore.eu/documentation/manuals/unicore6/files/tsi/tsi-manual.pdf
 
 
* Gateway 7.2.0 (expected on: 2015-01-21)
 
** Main changes: (including other products affected)
 
*** Now based on Apache HTTPClient 4
 
*** Many fixes for bugs and some security vulnerabilities (e.g. SSL POODLE)
 
*** For a full, detailed list of changes please refer to http://unicore.eu/changes/server.html
 
** Other information:
 
*** This is a major update. We recommend uninstalling any older (6.6) version that you may have, and re-install from scratch.
 
*** UNICORE 7 is backwards compatible with UNICORE 6
 
*** HTML doc http://unicore.eu/documentation/manuals/unicore6/files/gateway/manual.html
 
*** PDF doc http://unicore.eu/documentation/manuals/unicore6/files/gateway/manual.pdf
 
 
* Registry 7.2.0 (expected on: 2015-01-21)
 
** Main changes: (including other products affected)
 
*** New web services stack based on Apache CXF and Apache HTTPClient 4
 
*** Fix for the SSL POODLE security vulnerability
 
*** For a full, detailed list of changes please refer to http://unicore.eu/changes/server.html
 
** Other information:
 
*** This is a major update. We recommend uninstalling any older (6.6) version that you may have, and re-install from scratch.
 
*** UNICORE 7 is backwards compatible with UNICORE 6
 
*** HTML doc http://unicore.eu/documentation/manuals/unicore6/files/registry/registry-manual.html
 
*** PDF doc http://unicore.eu/documentation/manuals/unicore6/files/registry/registry-manual.pdf
 
 
* XUUDB 7.2.0 (expected on: 2015-01-21)
 
** Main changes: (including other products affected)
 
*** New web services stack based on Apache CXF and Apache HTTPClient 4
 
*** Fix for the SSL POODLE security vulnerability
 
*** For a full, detailed list of changes please refer to http://unicore.eu/changes/server.html
 
** Other information:
 
*** This is a major update. We recommend uninstalling any older (6.6) version that you may have, and re-install from scratch.
 
*** UNICORE 7 is backwards compatible with UNICORE 6
 
*** HTML doc http://unicore.eu/documentation/manuals/unicore6/files/xuudb/manual.html
 
*** PDF doc http://unicore.eu/documentation/manuals/unicore6/files/xuudb/manual.pdf
 
 
 
* UCC 7.x Expected on: TBD
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== LB ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== Gridsite ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== Proxyrenewal ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== CANL ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== gLite-security ==
 
* Release version w.k.j Expected on: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== gLExec-wn ==
 
 
* LCMAPS-plugins-C-PEP & EES(+xacml library)
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== CREAM ==
 
* BLAH
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
 
* CREAM
 
* Release version 1.16.5 Expected: 2015-01-30
 
** Main changes: (including other products affected)
 
*** [https://issues.infn.it/jira/browse/CREAM/fixforversion/11910 CREAM 1.16.5 fixes & new features]
 
** Other information:
 
 
== STORM ==
 
* Release version 1.11.5 - 07.01.2015
 
** Release notes can be found at: - http://italiangrid.github.io/storm/release-notes/StoRM-v1.11.5.html
 
* Release version 1.11.6 - 21.01.2015 - emergency
 
** Release notes can be found at: - http://italiangrid.github.io/storm/release-notes/StoRM-v1.11.6.html
 
 
== CREAM GE utils ==
 
* Release version X.Y.Z Expected: 2015-XX-YY
 
** Main changes:
 
*** Fixes:
 
****
 
*** New features:
 
****
 
** Other information:
 
***
 
 
== VOMS ==
 
* Release versions:
 
** VOMS Admin server v. 3.3.2 - released 28.01.2015
 
** Release Notes - http://italiangrid.github.io/voms/release-notes/voms-admin-server/3.3.2/
 
** VOMS Clients v. , VOMS API Java v.
 
** VOMS C APIs, native clients and server v.
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
*** VOMS Admin server 3.3.2 with the "skip_ca" fix - http://italiangrid.github.io/voms/release-notes/voms-admin-server/3.3.2/
 
 
** Other information:
 
 
== WMS ==
 
* Release version x.y.z Expected: 2013-xx-yy
 
** Main changes: (including other products affected)
 
** Other information:
 
 
== Globus ==
 
* Globus Toolkit version 6.0 was released 11 September 2014
 
** Updates in Fedora updates testing/EPEL testing:
 
*** EPEL5: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2812/
 
*** EPEL6: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2799/
 
*** EPEL7: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2843/
 
*** F19: https://admin.fedoraproject.org/updates/FEDORA-2014-11457/
 
*** F20: https://admin.fedoraproject.org/updates/FEDORA-2014-11364/
 
*** F21: https://admin.fedoraproject.org/updates/FEDORA-2014-11226/
 
** Please provide feedback in the tickets above.
 
** Main changes: Backwards compatible, no soname changes.
 
** Other information: The Grid Packaging Tools (GPT) will be dropped in favour of standard autotools. If you are relying on GPT tools or GPT metadata files, now is the time to migrate. The pkg-config support has been the preferred way to find Globus Toolkit dependencies a long time. The globus-makefile-header command will be replaced with a wrapper around pkg-config calls to provide some backward compatibility, but its use is not recommended. No GPT metadata files will be installed with the new release.
 
** Fixes for reported issues: The updates above have been edited to include fixes for the following issues:
 
***GGUS 106665 - Bad logging of IPv6 addresses in the gridftp server logs. Reported by STORM. Tested by STORM and DPM. https://github.com/globus/globus-toolkit/pull/8. Updated package: globus-gridftp-server-7.11-2
 
*** Memory leaks in ftp client control library. Reported and tested by FTS. https://github.com/globus/globus-toolkit/pull/9. Updated package: globus-ftp-control-5.11-2
 
* jGlobus 2.1.0 was released 26 September.
 
** Updates in Fedora 19+, EPEL 6+ testing and Debian unstable/Debian testing:
 
*** EPEL6: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-3072/
 
*** EPEL7: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-3087/
 
*** F19: https://admin.fedoraproject.org/updates/FEDORA-2014-12019/
 
*** F20: https://admin.fedoraproject.org/updates/FEDORA-2014-11982/
 
*** F21; https://admin.fedoraproject.org/updates/FEDORA-2014-12020/
 
 
== QCG ==
 
* Version 3.4.0 was released for SL5 and partialy (qcg-Broker) for SL6.
 
 
* Support for SL6 is planned together with new functionality for first update of 2015, curently in validation
 
* In preparation for the seame udpate (2015) also:
 
**  several updates of the packages, including a new versions of the QCG-Broker (support for voms) and QCG-Computing services.
 
 
= Report from WLCG MW Officer =
 
 
* open verifications are available at https://its.cern.ch/jira/secure/Dashboard.jspa?selectPageId=15100
 
 
= Other topics =
 
 
== XROOTD v.3 vs XROOTD v. 4 ==
 
 
* xrootd 4.1.1 and xrootd-compat 3.3.6 are in epel-testing for EPEL 5 and 6
 
** https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-4648 (EPEL 5)
 
** https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-4636 (EPEL 6)
 
* Buildroot overrides are in place for building packages in Koji against xrootd 4.1.1 for EPEL 5 and 6.
 
* Time for pushing the update to stable is being coordinated with DPM developers (dpm-xrootd).
 
** https://admin.fedoraproject.org/updates/dpm-xrootd-3.5.2-1.el5
 
** https://admin.fedoraproject.org/updates/dpm-xrootd-3.5.2-1.el6
 
 
= Actions (done and in progress) =
 
== Java 7 ==
 
* [https://wiki.egi.eu/wiki/URT:Java7 Java 7 - as dependency of released products/components ] - Please have a look and send comments, especially TP missing
 
 
== EPEL 7 ==
 
* [https://wiki.egi.eu/wiki/URT:EPEL7 Status of support of EPEL 7, together with SL7 or CentOS7] - Please have a look and send comments, especially TP missing
 
 
== SL5 & MySQL 5.0 vs. MySQL 5.X, x>=1 ==
 
 
* For more details see [[URT:SupportMysql5X|Middleware support of MySQL v. 5.x, x>=1]]
 
 
= AOB =
 
 
* Next meeting '''16 Feb. 2015, 15:00 CET'''
 
 
= Minutes =
 
 
* [Minutes 02-02-2015]
 
 
= Audio conference details =
 
<i>
 
Room link: http://connect.ct.infn.it/egi-inspire-sa1-ter/
 
 
Please provide you Name and product team/affiliation as Guest Name.
 
 
In left top corner you will find "Meeting->Audio Setup Wizard" Button which will help you to configure your audio.
 
 
You can test Your Computer with this link http://connect.ct.infn.it/common/help/en/support/meeting_test.htm
 
 
Adobe Connect tutorials: http://tv.adobe.com/show/learn-adobe-connect-8/
 
 
Adobe connect is flash-based, please if you have issues with your configuration try Chrome as browser.
 
</i>
 
 
''Back to the URT agendas list page: [[URT_meetings_agendas]]
 

Latest revision as of 14:27, 30 January 2015