Difference between revisions of "APEL/SSMInstallation"

From EGIWiki
Jump to: navigation, search
(ssm-1.0 - ssm-1.2)
Line 24: Line 24:
 
Installation and removal instructions are now packaged with the SSM in the README file.  If you would like to read it before you install the SSM, here is the version included with ssm-1.2: [[APEL/SSM/README12]].
 
Installation and removal instructions are now packaged with the SSM in the README file.  If you would like to read it before you install the SSM, here is the version included with ssm-1.2: [[APEL/SSM/README12]].
  
'''Please note''': the default configuration sends messages to the test server.  See [[APEL/SSMConfiguration]] for how to change the configuration.
+
'''Please note''': the default configuration sends messages to the CPU Accounting test server.  See [[APEL/SSMConfiguration]] for how to change the configuration.
  
 
== Older versions ==
 
== Older versions ==

Revision as of 16:34, 30 October 2012

SSM downloads are available at https://github.com/willrogers/ssm/downloads.

NOTE: Before you can send your messages to the Accounting server you must send your host certificate DN to the APEL-SUPPORT@JISCMAIL.AC.UK mailing list, e.g. output from running

openssl x509 -subject -noout -in hostcert.pem

Installing SSM

  • For details on the testing process, see this page: APEL/APELSSMExternalTesting
  • If you find any bugs please let us know about them: apel-ssm-test@mailtalk.ac.uk.

ssm-1.0 - ssm-1.2

The same package is installed for CPU accounting, StAR and Cloud accounting records.

Version 1.2 is the current version.

It changes the default messages location from the previous version:

  • OLD: /opt/apel/ssm/messages/
  • NEW: /var/opt/apel/messages/

Installation and removal instructions are now packaged with the SSM in the README file. If you would like to read it before you install the SSM, here is the version included with ssm-1.2: APEL/SSM/README12.

Please note: the default configuration sends messages to the CPU Accounting test server. See APEL/SSMConfiguration for how to change the configuration.

Older versions

There is now no reason to install an older version. Please install SSM 1.2 or above.